HowTo VestaCP - Менеджер версий php для Centos

localrow

New member
Мультиверсионность php на CentOS с VestaCP.
На есть скрипт, который добавляет репозиторий с уже собранными версиями php 5.5, 5.6 и 7.0. По умолчанию в CentOS 6.8 установлен php 5.4. В итоге после установки скрипта мы имеем все версии php начиная от 5.4.

Установка супер простая

Код:
wget https://raw.githubusercontent.com/Skamasle/sk-php-selector/master/sk-php-selector2.sh
bash sk-php-selector2.sh
Вывод установщика не очень многословен

MUb1lkH.png

После установки при редактировании виртуального хоста в web-шаблонах мы видим что появились новые пункты с новыми версиями php.

VCWdvg7.png

Пробуем переключится и смотрим phpinfo

Как видим, все работает.
 

nulstre

New member
PHP 5.4 is now deprecated and no longer supported. You must get at least PHP 5.6 as of this writing. Also, if you install CentOS 6, you should be using Cent OS 6.9 instead.
 

nail_90

New member
Что лучше выбрать для нагруженного интернет магазина VestaCP или CentOS Weba Panel ? CentOS Weba Panel манит коробочным решением с Nginx и Varnish ...
 
Сверху